NFsec Logo

Lista wrażliwych pakietów dla Arch Linux

29/09/2016 w Administracja, Bezpieczeństwo Brak komentarzy.

J

ak wiemy zdezaktualizowane i podatne pakiety zdarzają się dość często w życiu cyklu oprogramowania. W dystrybucji Arch aktualizacje pojawiają się na bieżąco, ponieważ wykorzystywane są najnowsze wersje pakietów oprogramowania z kanału upstream. Gdy pojawia się aktualizacja, to nie potrwa to długo, że staje się ona dostępna i może być zainstalowana za pomocą menedżera pakietów packman. Jednym z problemów było brak możliwości szybkiego sprawdzenia, czy w naszym systemie znajdują się jakieś wrażliwe pakiety. Dopóki nie pojawiło się narzędzie arch-audit, które korzysta z danych udostępnionych przez zespół Arch CVE Monitoring Team i w prosty sposób potrafi przedstawić listę niebezpiecznych paczek wraz z numerami CVE.

Więcej informacji: arch-audit

Ofiary javy

07/09/2014 w Bezpieczeństwo Brak komentarzy.

J

ava jest popularnym językiem programowania. Dwie główne sprawy tej popularności to bezpieczeństwo oraz dostępność bibliotek i komponentów w jej dużym ekosystemie. Odkąd większość aplikacji Javy robi użytek z tego ekosystemu, a wykorzystywane biblioteki posiadają zależności w innych bibliotekach – zapewnienie integralności bezpieczeństwa takich aplikacji staje dość trudne. Niektóre badania wyjawiły poważną skalę tego problemu. W przedstawionej prezentacji przyjrzano się 1261 wersji z 31 różnych bibliotek, które zostały pobrane z Centralnego Repozytorium Mavena. Jedną z strategii, która taką integralność jest w stanie zapewnić na przyzwoitym poziomie jest wymuszenie przeskanowania listy zależnych bibliotek budowanej aplikacji w bazie danych znanych podatności i zagrożeń – CVE.
[ czytaj całość… ]

Backportowanie patchy z RHEL 6 do CentOS 6 na przykładzie httpd 2.2.15

22/09/2011 w Administracja, Bezpieczeństwo Brak komentarzy.

Z

e względu na opóźnienia w wydawaniu aktualizacji bezpieczeństwa w dystrybucji CentOS – w przypadku krytycznych błędów aplikacji istnieje możliwość skorzystania z łatek dostarczonych przez jego protoplastę, czyli RedHat Enterprise. Za przykład może posłużyć niedawna luka znaleziona w serwerze Apache umożliwiająca przeprowadzenie ataku DoS, w tym wersji Apache’a 2.2.15 dostarczonego wraz z 6’stą wersją tej dystrybucji, a do której do dziś nie została wydana poprawka.
[ czytaj całość… ]