NFsec Logo

macOS – Apple Unified Log

05/03/2021 w Techblog Możliwość komentowania macOS – Apple Unified Log została wyłączona

F

irma Apple ogłosiła wprowadzenie formatu AUL (ang. Apple Unified Log) na swojej konferencji dla developerów w 2016 roku – WWDC. Przed AUL system macOS opierał się na tradycyjnych formatach rejestrowania systemu Unix, takich jak syslog lub własnym – Apple System Log (ASL). Jednak Apple doszło do wniosku, że potrzebuje jednego, znormalizowanego formatu rejestrowania na platformach macOS, iOS, tvOS i watchOS. Zmiana została wprowadzona od wersji macOS 10.12 Sierra. Format cały czas poddawany jest ewolucji np. liczba zdefiniowanych logowanych pól od czasu wydania Sierry do Cataliny (10.15) wzrosła z 16 do 27. W formacie AUL firma Apple poprawiła kompresję logowanych danych, przechodząc do formatu binarnego, co pozwala na zmaksymalizowanie gromadzenia dużej ilości informacji przy jednoczesnym zminimalizowaniu efektu obserwatora.
[ czytaj całość… ]

Protonmail – sprawdzenie daty utworzenia adresu e-mail

28/12/2020 w Techblog Możliwość komentowania Protonmail – sprawdzenie daty utworzenia adresu e-mail została wyłączona

J

eśli interesuje nas sprawdzenie daty utworzenia danego adresu e-mail (nie mylić z datą stworzenia konta) w protonmail – wystarczy skorzystać z API:

curl -q 'https://api.protonmail.ch/pks/lookup?op=index&search=admin@protonmail.com'

Odpowiedź typu:

info:1:1
pub:747752ef11868e4bfb4c0c3e9f832cbb57f25faa:1:2048:1461078056::
uid:admin@protonmail.com <admin@protonmail.com>:1461078056::

– oznacza, że dany adres e-mail istnieje, a 1461078056 znacznik czasu w formacie daty epoch. Wystarczy teraz wydać polecenie, które zamieni nam je na czas przyjazny człowiekowi: date -r 1461078056 (*BSD) / date -d @1461078056 (Linux) – Tue Apr 19 17:00:56 CEST 2016 / wtorek, 19 kwietnia 2016 17:00:56 GMT+02:00.

Odpowiedź typu:

info:1:0

– oznacza, że dany adres e-mail nie istnieje.

Jeśli zamienimy teraz operację „index”, na „get” będziemy w stanie pobrać publiczny klucz PGP konta e-mail:

curl -q 'https://api.protonmail.ch/pks/lookup?op=get&search=admin@protonmail.com' \ 
-o key.pgp
root@darkstar:~# gpg --list-packets key.pgp

# off=0 ctb=c6 tag=6 hlen=3 plen=269 new-ctb
:public key packet:
	version 4, algo 1, created 1461078056, expires 0
	pkey[0]: [2048 bits]
	pkey[1]: [17 bits]
	keyid: 9F832CBB57F25FAA
# off=272 ctb=cd tag=13 hlen=2 plen=43 new-ctb
:user ID packet: "admin@protonmail.com "

Lista serwerów ProtonVPN.Więcej informacji: ProtOSINT

Obsługa DoH w Mikrotik

02/07/2020 w Techblog Możliwość komentowania Obsługa DoH w Mikrotik została wyłączona

W wersji RouterOS 6.47 zostało dodane wsparcie DNS over HTTPS (RFC8484), czyli wykonywanie zapytań DNS przez protokół HTTPS. Jeśli używamy wybranego modelu w naszej sieci domowej (przykład był testowany na RB951Ui-2HnD) warto rozważyć podniesienie RouterBOARD do wydania wypuszczonego 2 czerwca 2020 r. Pierwszym krokiem jest ściągnięcie i import bazy urzędów (CA):

/tool fetch url=https://curl.haxx.se/ca/cacert.pem
/certificate import file-name=cacert.pem passphrase=""

Następnie dodajemy statyczne wpisy DNS, które umożliwią komunikację z serwerem DoH:

/ip dns static add name="cloudflare-dns.com" type=A address="104.16.248.249"
/ip dns static add name="cloudflare-dns.com" type=A address="104.16.249.249"

Czyścimy aktualnie używane serwery DNS:

/ip dns set servers=""

Ustawiamy serwer DoH:

/ip dns set use-doh-server="https://cloudflare-dns.com/dns-query"
/ip dns set verify-doh-cert=yes

Czyścimy dotychczasową pamięć cache:

/ip dns cache flush

Teraz możemy wejść na stronę: 1.1.1.1/help i sprawdzić, czy komunikat Using DNS over HTTPS (DoH) posiada wartość Yes. Analogicznie możemy ustawić inne serwery DoH np. https://dns.google/dns-query, https://dns.quad9.net/dns-query, https://mozilla.cloudflare-dns.com/dns-query.

Obchodzenie wymogu logowania serwisu instagram.com

21/06/2020 w Techblog Możliwość komentowania Obchodzenie wymogu logowania serwisu instagram.com została wyłączona

S

erwis instagram jakiś czas temu wprowadził wymóg logowania po przeglądnięciu kilku zdjęć. Znajomy poprosił mnie o zbadanie, czy istnieją istnieją alternatywne metody, aby ominąć tą restrykcję. Najszybszym i najprostszym sposobem jest wykorzystanie serwisu ImgInn, który wykorzystuje API serwisu instagram. Wystarczy adres w postaci: https://instagram/mike.wazowski zamienić na: https://imginn.com/mike.wazowski, co daje nam pełen dostęp do obrazów z danego profilu z możliwością ich ściągnięcia. Serwis ten umożliwia również usuwanie danych wybranych kont – dlatego jeśli nie możemy wykonać podglądu z tej pozycji pozostaje nam dodanie własnego filtru do dodatku uBlock Origin:

instagram.com##._Yhr4.RnEpo
instagram.com##body:style(overflow:visible !important;)

lub ręcznie za pomocą „Narzędzi programistycznych” (F12 w przeglądarce) zmieniamy kod HTML z:

<body class style="overflow: hidden;">

na:

<body class style="overflow: visible;">

oraz wyszukujemy element HTML div z frazą "_Yhr4" w nazwie klasy i go cały usuwamy. Od tej chwili możemy swobodnie przewijać stronę, ale niestety nie możemy powiększać obrazów poprzez klikanie na nie. Dla rozwiązania tego problemu użyjemy stałego skrótu URL. Wystarczy skopiować adres dowolnego obrazka np.:

https://www.instagram.com/p/wWwNfseCwPl/

i dodać do niego frazę: /media/?size=l, czyli:

https://www.instagram.com/p/wWwNfseCwPl/media/?size=l

Więcej informacji: Wątek na Twitterze

Kupujesz i po latach rekla(spa)mujesz

17/06/2016 w Techblog Możliwość komentowania Kupujesz i po latach rekla(spa)mujesz została wyłączona

Z

acznijmy od początku. Społecznościówki (Google+, Facebook, LinkedIn), e-banki, e-płatności, e-commerce, hotele itp. – wszystkie wymagają podania adresu e-mail. Do prawie wszystkich można zalogować się w klasycznym układzie typu: e-mail / hasło. Nie trzeba już wymyślać sobie kozackiego, jedynego nicku, ponieważ serwisy zaczynają traktować adresy e-mail jako unikatowe identyfikatory użytkowników z którymi w ten sposób mogą prowadzić „bezpieczną” komunikację. Wszechobecne dzielenie się adresem e-mail z technicznego punktu widzenia nie jest złe, ale na dłuższą metę powoduje kilka irytujących problemów – spam, poznanie Twojego loginu do poczty przy wycieku danych itd. Niektóre z nich można rozwiązać lub uczynić znacznie prostszymi za pomocą aliasów pocztowych.
[ czytaj całość… ]

Wymuszamy, aby nasz Android skorzystał z LTE/3G/2G zamiast WiFi

14/05/2016 w Techblog Możliwość komentowania Wymuszamy, aby nasz Android skorzystał z LTE/3G/2G zamiast WiFi została wyłączona

W

końcu znalazłem trochę czasu, aby za radą Hendrego zobaczyć, co tak naprawdę wychodzi z mojego telefonu (aktualnie korzystam z radioodbiornika wyposażonego w Android w wersji 6.0). Analogicznie, jak w poradniku przekierowałem streaming pakietów (na razie tylko UDP) z routera Mikrotik do komputera, na którym nasłuchiwał Wireshark filtrując tylko ruch z telefonu. Pierwszym adresem, jaki pojawił się na ekranie po włączeniu WiFi na urządzeniu był:
[ czytaj całość… ]

Atlas całego świata

02/01/2015 w Techblog Możliwość komentowania Atlas całego świata została wyłączona

P

rogram RIPE Atlas jest największą na świecie siecią pomiarową Internetu. Idea uczestnictwa w programie jest bardzo prosta: w zamian za podłączenie sondy do swojej sieci w celu prowadzenia badań i pomiarów przez zarządców sieci Atlas oraz innych uczestników – otrzymujemy dostęp do każdej innej sondy sieci Atlas na całym świecie (w tym momencie: 7.5 tysiąca) z możliwością uruchomienia własnych testów wydajności. To pozwala na sprawdzanie i mierzenie dostępów do własnych serwerów / routerów itd. z różnych miejsc na całym świecie w ciągu kilku minut.

Więcej informacji: RIPE Atlas, czyli największa sieć pomiarowa

Hosting statycznych stron i treści w Google Drive

26/12/2013 w Techblog Możliwość komentowania Hosting statycznych stron i treści w Google Drive została wyłączona

G

oogle Drive umożliwia nie tylko przechowywanie zdjęć i innych dokumentów, ale również statycznych stron HTML, plików JavaScript oraz CSS. W tym celu wystarczy:

  • Stworzyć nowy folder i udostępnić go jako publiczny,
  • Wgrać do tego folderu pliki HTML, JS, CSS,
  • Zaznaczyć wybrany plik HTML i wybrać z menu Więcej: Otwórz za pomocą: Przeglądarka Dysku Google
  • W otworzonej zakładce z przeglądarką ponownie kliknąć Pogląd i skopiować URL

Tak otrzymany URL: https://googledrive.com/host/1B4SBiW70ZQreMzZtbktoQ1k0VHM/static.html (gdzie host to nazwa udostępnionego folderu) możemy wkleić w kod innej strony – plik static.html zamienić na np. static.css itd. – wykorzystując infrastrukturę Google do celów hostingowych małych i prostych plików.

Więcej informacji: Host webpages on Google Drive

Cisco Linksys WRT160NL – alternatywny firmware

11/11/2013 w Techblog Możliwość komentowania Cisco Linksys WRT160NL – alternatywny firmware została wyłączona

O

soby posiadające router firmy Cisco Linksys – model WRT160NL, które są zainteresowane instalacją alternatywnego firmware niż ten dostarczony przez firmę Cisco np. pochodzący z projektów: DD-WRT, OpenWRT lub Gargoyle mogą skorzystać z strony Cristian’a Radu, który dostarcza (linkuje) najnowsze wydania oprogramowania z tych projektów pod ten model. Firmware do innych modeli i producentów z projektu DD-WRT możemy znaleźć pod tym adresem.

Instalacja VirtualBox na OS X z linii poleceń

15/05/2013 w Techblog Możliwość komentowania Instalacja VirtualBox na OS X z linii poleceń została wyłączona

O

statnio zaistniała potrzeba instalacji VirtualBoksa na Mac OS X Mini, który nie był wyposażony w żaden monitor, klawiaturę czy myszkę – tzw. headless station. Oczywiście instalacja VirtualBoksa z linii poleceń nie jest aż tak wymagająca, jak administracja nim za pomocą poleceń, ale pozwala na szybkie osiągnięcie celu bez jednego kliknięcia:
[ czytaj całość… ]